Maps not working on some Flow instances
Incident Report for Akvo
Resolved
This incident has been resolved.
Posted 6 months ago. Feb 20, 2018 - 15:14 CET
Identified
The issue has been identified and a fix is being implemented.
Posted 6 months ago. Feb 20, 2018 - 13:43 CET
Investigating
We are currently experiencing temporary issues on Flow's Maps tab. This affects only some users, not all.
Posted 6 months ago. Feb 20, 2018 - 13:17 CET