SSL encryption problem
Incident Report for Akvo
Resolved
The SSL certificate issues has been resolved. Thanks for your patience.
Posted Sep 09, 2021 - 15:16 CEST
Update
We continue to investigate the issue with our SSL certificates. Our apologies for the inconvenience. We expect to have it resolved shortly.
Posted Sep 09, 2021 - 14:28 CEST
Investigating
Our SSL certificate didn't renew automatically as it should. We're investigating and fixing the problem
Posted Sep 09, 2021 - 11:13 CEST
This incident affected: Akvo.org, Akvo Flow, Akvo Lumen, Akvo RSR, Akvo Pages, Akvo Sites, and Akvopedia.org.