Akvo email is currently down
Incident Report for Akvo
Resolved
We are receiving and sending mail as normal.

with thanks
The Akvo Team
Posted Oct 08, 2015 - 08:32 CEST
Investigating
Our mail hosting company, Capitar IT, are experiencing issues which are not yet resolved.
We can currently not send/receive emails to/from akvo.org or akvoflow.org domains.

Please contact us via additional contact details on our website: http://akvo.org/contact-info/

A full update will be issued once our mail system is back online.

with thanks
The Akvo Team
Posted Oct 07, 2015 - 11:55 CEST