Akvo FLOW reporting service is down
Incident Report for Akvo
Resolved
Akvo FLOW reporting service is now back & running!
Posted Jan 30, 2014 - 10:13 CET
Investigating
We are currently investigating the cause
Posted Jan 30, 2014 - 10:02 CET