Akvo Flow reporting service is currently down
Incident Report for Akvo
Resolved
The issues around the reporting functionality of Flow are now resolved and the reports work as expected.

Thank you for your patience
Akvo Flow team
Posted Jun 23, 2016 - 11:10 CEST
Investigating
We are currently experiencing issues with Akvo Flow services - our tool which enables users do download raw data reports and other reports. The reporting feature is thus not working at this moment and we are focusing on fixing it at this moment.

Akvo Flow team
Posted Jun 23, 2016 - 10:59 CEST