Akvo.org issues
Incident Report for Akvo
Resolved
This incident has been resolved.
Posted Feb 10, 2015 - 09:46 CET
Identified
There seems to be an issue with our DNS provider, PointHQ. We have made some changes to accommodate this issue so the site should be stable now but will be monitored.
Posted Feb 10, 2015 - 09:46 CET
Investigating
Akvo.org is currently unavailable. We are investigating & hope to be back shortly.

The Akvo Team
Posted Feb 10, 2015 - 09:13 CET