Akvo.org & Akvo Sites down right now
Incident Report for Akvo
Resolved
The sites are now available.

The Akvo Team
Posted May 13, 2015 - 12:38 CEST
Investigating
It seems our provider, CloudVPS, are experiencing some network issues. Our Akvo Sites and Akvo.org are currently unavailable.

We will keep you updated.

The Akvo Team
Posted May 13, 2015 - 12:35 CEST