Issue with shared dashboards or visualisations in Lumen
Incident Report for Akvo
Resolved
This incident has been resolved.
Posted about 1 month ago. Dec 07, 2017 - 13:27 CET
Investigating
We are currently investigating this issue.
Posted about 1 month ago. Dec 07, 2017 - 10:14 CET