Akvo RSR - degraded performance
Incident Report for Akvo
Resolved
After this morning's fix, the performance of RSR has returned to normal.
Posted May 11, 2016 - 11:12 CEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 11, 2016 - 10:12 CEST
Identified
We have identified the issue causing intermittent 504's and slow performance by Akvo RSR over the past few days.

Certain API calls were taking a very long time to complete - and thus causing 504 timeout errors and caused severely degraded performance in RSR and partner sites. It turns out, that the culprit is a recent code change to RSR which was seeing the RSR API pull in extra IATI data from a separate database and dramatically increasingly the response payload.

A fix will be included in the next release of RSR this week, which will solve this problem.

with thanks
The Akvo team
Posted May 09, 2016 - 15:37 CEST
Investigating
It seems we have continued issues with connectivity to our Akvo RSR server.
We are trying to identify the cause and will send out a notification once the issue is resolved.

Thank you for your patience.

The Akvo team
Posted May 09, 2016 - 08:48 CEST