Akvo FLOW particular instances not uploading data
Incident Report for Akvo
Resolved
Akvo FLOW is fully operational. All instances have been deployed.
Posted Oct 03, 2013 - 14:43 CEST
Update
There are still a few instances which need to be deployed, we are still working to resolve this as quickly as possible.
Posted Oct 03, 2013 - 14:30 CEST
Identified
There is an urgent issue in Akvo FLOW which we just discovered which will prevent data being uploaded from devices.
Data collection is not affected, and already collected data will not be lost.
This problem affects the FLOW instances listed below.
Affected instances
---------------
- watermapmonitordev
- flowliberia
- flowirc
- flowsierraleone
- flowcrepa
- flowcongo
- flowcommunitysciences
- flowaglimmerofhope
- flowachildsright

We have sent a mail to the contact persons of those instances with the lower part of this mail included to let them know what to do. The newer instances are all ok.

What a user sees
--------------
When a user tries to sync data from the device, this will fail, and show the regular failed-upload error message. Data is still saved on the device as usual.

What needs to be done
-------------------
1) Temporarily stop data collection until this issue is resolved

2) as a backup, please copy the "surveyal" folder (which can be found in the 'fieldsurvey' folder on the sd card) to your computer.

3) a new version of the app, which we will sent around today, needs to be installed on top of the old one. It is very important that you do NOT uninstall the old version of the app before you install the new one. This will delete the database. Instead, try to install the new version directly, for example through gmail. This will prompt you with a message like ''this app will replace an existing one. Ok?". This is safe to do.

4) when the new app is started, the phone will connect with the internet and upload data as usual.

As a backup, the data in the surveyal folder can be uploaded directly using the bulk upload tool. If you need assistance with this, please let us know.

Technical cause
-------------
In order to upload data to S3, the devices use an internal 'password', which unexpectedly expired on 2 October. This problem affects the FLOW instances that were created during the FLOW 1.0 period, which used a different setting for the expiration date. Unfortunately, the only solution to this problem is installing a version of the FLOW App which has a newer internal S3 password.
Posted Oct 02, 2013 - 15:48 CEST
Investigating
There is an urgent issue in Akvo FLOW which we just discovered which will prevent data being uploaded from devices.
Data collection is not affected, and already collected data will not be lost.
Posted Oct 02, 2013 - 15:46 CEST